[PowerDNS][ARM] ARMボードでコンパイルしたPowerDNS recursorでAPIが取得できない? その2

AIX、UNIX、LinuxARM

相割らず調べ物中です。

Debian -- Details of package pdns-recursor in sid
PowerDNS Recursor

互換性の問題でよくあげられるDebianを確認してみたところ、2015/03/04現在、最新は3.6.2。
で気になったのは関連パッケージの方でして、Debianのパッケージを導入しようとしたところ、以下のパッケージのバージョンが低いらしい。

~$ sudo dpkg -i pdns-recursor_3.6.2-2_armhf.deb
Selecting previously unselected package pdns-recursor.
(Reading database ... 50882 files and directories currently installed.)
Preparing to unpack pdns-recursor_3.6.2-2_armhf.deb ...
Unpacking pdns-recursor (3.6.2-2) ...
dpkg: dependency problems prevent configuration of pdns-recursor:
pdns-recursor depends on libstdc++6 (>= 4.9); however:
Version of libstdc++6:armhf on system is 4.8.2-19ubuntu1.
pdns-recursor depends on init-system-helpers (>= 1.18~); however:
Version of init-system-helpers on system is 1.14.

dpkg: error processing package pdns-recursor (--install):
dependency problems - leaving unconfigured
Processing triggers for ureadahead (0.100.0-16) ...
Errors were encountered while processing:
pdns-recursor

Debianの方はGNU 標準 C++ ライブラリ v3 のバージョンが4.9らしいんですが、Ubuntu 14.04ではまだ4.8。コンパイル自体は通るけど、この辺りが関係するんですかねぇ・・・ 
ソースを読む能力が無いので辛い・・・

Ubuntu 14.10では4.9になっているようなので、上げて確かめてみるのもひとつの手なのだろうか・・・

メーリングリストに質問を投げようかとも考えましたが、英語不自由につきどう投げたものか・・・

この記事を書いた人

kometchtech

うつ病を患いながら、IT業界の末席にいるおっさんエンジニア。科学計算をしたことがないのに、HPC分野にお邪魔している。興味のある分野で学習したことをblogにまとめつつ、うつ病の経過症状のメモも置いておく日々。じつはRouterboard User Group JPの中の人でもある。 Amazon欲しいものリスト / Arm板を恵んでくれる人募集中

いつか、そのとき、あの場所で。rev.2
タイトルとURLをコピーしました