[CloudCoreRouter][NW] L2TP/IPsecの設定方法(途中)。

2013-05-10 10:32:52mikrotik, Networkipsec, l2tp, Mikrotik, Routerboard, RouterOS

とりあえずL2TP/IPsecでの接続が出来たのでメモ。
と言っても内部へのルーティングがうまくいかないので、あくまで外につながっただけという状態ですが。
これから内部へ接続できるようにするにはどうすればよいか確認していこうかと思います。

[admin@MikroTik] > export compact
# may/09/2013 11:27:50 by RouterOS 6.0rc14
# software id =
#
/ip pool
add name=VPN-pool ranges=192.168.70.10-192.168.70.20
/ppp profile
add change-tcp-mss=yes dns-server=8.8.8.8,8.8.4.4 name=VPN-sever only-one=no \
remote-address=VPN-pool use-ipv6=default
/interface l2tp-server server
set authentication=mschap2 default-profile=default enabled=yes max-mru=1460 max-mtu=1460
/ip firewall filter
add chain=input dst-port=500 protocol=udp
add chain=input dst-port=1701 protocol=udp
add chain=input dst-port=4500 protocol=udp
add chain=input protocol=ipsec-esp
add chain=output dst-port=1701 protocol=udp
add chain=output dst-port=4500 protocol=udp
add chain=output dst-port=500 protocol=udp
add chain=output protocol=ipsec-esp
/ip ipsec peer
add exchange-mode=main-l2tp generate-policy=port-override hash-algorithm=sha1 \
nat-traversal=yes secret=xxxxxxxxx
/ip route
/ppp secret
add name=test password=test profile=VPN-sever service=l2tp

以下のコマンドを入力することで、ipsecのdebugを行うことが出来ます。

[admin@MikroTik] system logging add topics=ipsec action=memory 
日経BP (2017-10-17)
売り上げランキング: 38,546
ネットワーク超入門講座 第4版
三上 信男
SBクリエイティブ
売り上げランキング: 3,781
この記事を書いた人

kometchtech

うつ病を患いながら、IT業界の末席にいるおっさんエンジニア。科学計算をしたことがないのに、HPC分野にお邪魔している。

興味のある分野で学習したことをblogにまとめつつ、うつ病の経過症状のメモも置いておく日々。

じつはRouterboard User Group JPの中の人でもある。

Amazon欲しいものリスト / Arm板を恵んでくれる人募集中

2013-05-10 10:32:52mikrotik, Networkipsec, l2tp, Mikrotik, Routerboard, RouterOS