2019/06/27 09:41AIX、UNIX、Linuxipsec,linux,strongswan,swanctl,vpn

swanctl-strongSwan

はじめに

先日の以下のようなstrongSwanを使った記事を書きましたが、最近はstrongSwanはswanctlというものを実装し、こちらのほうがipsecのconfが記述しやすくなっています。手元の環境もswanctlに置き換えてみました。

2019/06/24 10:49AIX、UNIX、Linux,Containercontainer,docker,ipsec,iptables,linux

vanveenjf-1136697-unsplash
photo by unsplash.

はじめに

頭悪い内容の記事で申し訳ありません。

とあるdockerホスト側にIPsecトンネルを張っていたのですが、Container側からの通信をdockerホスト側のIPsecトンネルに流すにはどうすれば良いのか悩んだので記事にしておきます。知ってる人には簡単なことかもしれませんが・・・

2018/06/03 11:11Ubuntu18.04,config,ipsec,l2tp,linux,networkmanager,ubuntu,vpn

ubuntu 14.04、16.04とUbuntu Desktopを使用した際に、L2TP/Ipsecを使用する方法を調べてきましたが、18.04 LTSでも設定方法はあります。しかし、以前と同様に標準ではその手段は用意されておらず、別途導入する形になります。

しかし、以前よりは導入も設定も簡単になっているような気がします。

過去に取り上げた記事は以下の通り。

2015/01/14 10:10AIX、UNIX、Linux,Ubuntu14.04,ipsec,l2tp,Network Manager L2TP plugin,networkmanager,ubuntu,vpn

Ubuntu Desktopを使用していて、外出中にちょっと自宅などに接続するためにVPNを使用することもあるかと思いますが、Ubuntu 14.04などではNetworkManagerから設定できるのはPPTPしかありません。
会社などに接続しようと思うと、L2TP/IPsecなどを使用することが多いと思うので、これだとちょっと困ると思います。

もちろんOpenswanなどを手で設定し、実行することで接続させることができますが、できればNetworkManagerで完結させたいところです。

ほぼ標準的に使用されているのは、Openswan、xl2tpd、l2tp-ipsec-vpnの組み合わせだと思いますが、どうやらパスワードが渡せず、都度修正しないと接続ができない不具合があったりするみたいです。

https://qiita.com/masnagam/items/3603cd9314212c18c382

ということで代わりになるツールは無いかと探したところあったのでご紹介。

https://launchpad.net/~seriy-pr/+archive/ubuntu/network-manager-l2tp

2013/05/10 10:32mikrotik,Networkipsec,l2tp,Mikrotik,Routerboard,RouterOS

とりあえずL2TP/IPsecでの接続が出来たのでメモ。
と言っても内部へのルーティングがうまくいかないので、あくまで外につながっただけという状態ですが。
これから内部へ接続できるようにするにはどうすればよいか確認していこうかと思います。

[admin@MikroTik] > export compact
# may/09/2013 11:27:50 by RouterOS 6.0rc14
# software id =
#
/ip pool
add name=VPN-pool ranges=192.168.70.10-192.168.70.20
/ppp profile
add change-tcp-mss=yes dns-server=8.8.8.8,8.8.4.4 name=VPN-sever only-one=no \
remote-address=VPN-pool use-ipv6=default
/interface l2tp-server server
set authentication=mschap2 default-profile=default enabled=yes max-mru=1460 max-mtu=1460
/ip firewall filter
add chain=input dst-port=500 protocol=udp
add chain=input dst-port=1701 protocol=udp
add chain=input dst-port=4500 protocol=udp
add chain=input protocol=ipsec-esp
add chain=output dst-port=1701 protocol=udp
add chain=output dst-port=4500 protocol=udp
add chain=output dst-port=500 protocol=udp
add chain=output protocol=ipsec-esp
/ip ipsec peer
add exchange-mode=main-l2tp generate-policy=port-override hash-algorithm=sha1 \
nat-traversal=yes secret=xxxxxxxxx
/ip route
/ppp secret
add name=test password=test profile=VPN-sever service=l2tp

以下のコマンドを入力することで、ipsecのdebugを行うことが出来ます。正確に言うとipsecに関するlog出力がdebugレベルに変更になり、設定変更以降debug出力されるようになります。

[admin@MikroTik] system logging add topics=ipsec action=memory