[ #routerboard ][自分用メモ] 2つのISPを正副自動的に切り替えるようにしてみる。

mikrotikNetwork
Untitled_20150518014052650.png

自宅や会社にてプロバイダを予備を含めて複数契約している場合、何かプロバイダ側に問題が発生し、接続先プロバイダを切り替える必要があったりするときがあると思います。

そういう時は以下のように設定してやると自動的に切り替えてくれるようになると思います。

今回はCLIでの設定を記載しておきます。GUIでのご希望があればForumなどでリクエストしていただけると、そちらに書こうと思います。

確認環境:

  • RouterOS 6.28(CCR1009-8G-1S-1S+)

手順

ISP1への接続を、Ether1ポート、ISP2への接続をEther2ポートするとします。

1. PPPoEクライアントの設定

/interface pppoe-client
add add-default-route=yes default-route-distance=5 allow=pap,chap \
	comment=ISP1 disabled=no interface=ether1 \
	max-mru=1454 max-mtu=1454 name=ISP1 password=P@ssw0rd profile=\
	default-encryption user=user1@isp
add add-default-route=yes default-route-distance=10 allow=pap,chap \
	comment=ISP2 disabled=no interface=ether2 \
	max-mru=1454 max-mtu=1454 name=ISP2 password=P@ssw0rd profile=\
	default-encryption user=user2@isp

ここで注意する点は、add-default-routedefault-route-distanceの2つのパラメータです。
add-default-routeは、接続先をデフォルトゲートウェイとして設定する、default-route-distanceはデフォルトゲートウェイに対する重み付けになります。
この重み付けが正副の指定及び切り替えを指定するためのもので、default-route-distanceの数値が小さいほうが優先されます。

この場合はISP1:5、ISP2:10なので、正がISP1、副がISP2になります。
基本的には常時接続になると思いますが、必要時以外は接続しておきたくない場合は、dial-on-demandパラメータを有効にします。

ただし、dial-on-demandを有効にすると、デフォルトゲートウェイの重み付けが接続時にならないと有効にならないため、うまく正副切り替わらないと思います。

そういう場合は、add-default-route=noにして一旦、自動的にデフォルトゲートウェイを設定しないようにします。

そして、以下の設定項目でルートを手動で設定してやることで、上記と同じようにすることが出来ます。

/ip route
add check-gateway=ping distance=5 gateway=ISP1 scope=10
add check-gateway=ping distance=10 gateway=ISP2 scope=10

常時接続が有効になっているようであれば、ゲートウェイに対してpingもしくはarp監視ができるので、これを有効にしておくと、なにかISP側に問題があった場合、正副自動的に切り替えられるようになると思います。

ちなみにこの設定の場合、正が正常状態に戻った場合は切り戻されるようになります。
切り戻しは必要ないよという場合は、default-route-distanceの数値を一緒にするなどして於けば良いと思います。

問題などあればご指摘ください。

Manual:Interface/PPPoE - MikroTik Wiki
この記事を書いた人

kometchtech

うつ病を患いながら、IT業界の末席にいるおっさんエンジニア。科学計算をしたことがないのに、HPC分野にお邪魔している。興味のある分野で学習したことをblogにまとめつつ、うつ病の経過症状のメモも置いておく日々。じつはRouterboard User Group JPの中の人でもある。 Amazon欲しいものリスト / Arm板を恵んでくれる人募集中

いつか、そのとき、あの場所で。rev.2
タイトルとURLをコピーしました