AIX、UNIX、Linux,ARMAArch64,ARM,ARM64,cqueue,kernel,knot,knot resolver,lua,luajit

最初に

過去から今まで色々と情報を書いてきましたが、どうやらknot resolver v5.1.3で対応されたようです。

2019/08/16 10:58AIX、UNIX、Linux,ARMAArch64,ARM,ARM64,cqueue,gdb,kernel,knot,knot resolver,lua,luajit

1回、2回と続いてきたこのシリーズ。

この問題はluajitがAArch64に対応していないことに起因する問題なわけですが、luajitの開発は少なくとも現在は活発ではないようで、commitなどをほとんどされていないように見えます。

しかしながら最近はAArch64の環境が増えてきたことから、この手の問題で困っている人が増えてきているようで、luajitを含めてlua関連ライブラリのところでは困っている書き込みが良くあります。

knot resolverについても結局は関連するライブラリ側で対応してもらうことになったようです。